Herramientas personales

Modo cliente y modo repetidor en openwrt

De Seguridad Wireless

Saltar a: navegación, buscar

Modo cliente y modo repetidor en Openwrt

He estado leyendo y he encontrado una forma sencilla de poner nuestra fonera con firmware Openwrt en los modos cliente y repetidor, simplemente con editar algún que otro archivo.

Modo Repetidor

Archivo: /etc/config/wireless

config wifi-device wifi0

option type atheros
option channel 6 #Especificamos el canal en que trabajaremos

config wifi-iface #Configuración de la interface que se conectara al AP a repetir

option device wifi0
option network wan
option mode sta
option ssid Nombre_de_la_red_a_repetir
option encryption wep
option key 1
option key1 XXXXXXXXX #Aquí va la clave WEP de la red wireless

config wifi-iface #Configuración del interface en Modo AP

option device wifi0
option network lan
option mode ap
option ssid Nombre_de_la_red
option encryption wep
option key 1
option key1 XXXXXXXXXXXXXXX #Aqui la clave WEP. Se recomienda utilizar la misma clave WEP que empleamos antes.


Archivo: /etc/config/network

config interface loopback

option ifname lo
option proto static
option ipaddr 127.0.0.1
option netmask 255.0.0.0

config interface lan

option ifname eth0
option type bridge
option proto static
option ipaddr 192.168.2.1
option netmask 255.255.255.0

config interface wan

option ifname ath1 #Esto puede variar aunque por defecto la interface Modo STA se auto-asigna la interface ath1
option proto dhcp

Por ultimo, o bien reiniciamos nuestra fonera, o sino tenemos ganas de esperar ejecutamos lo siguiente:

/etc/init.d/network restart

Modo Cliente

Archivo: /etc/config/wireless

config wifi-device wifi0

option type atheros
option channel 6 #Especificamos el canal en que trabajaremos

config wifi-iface #Configuración de la interface que se conectará al AP a conectarse

option device wifi0
option network wan
option mode sta
option ssid Nombre_de_la_red_a_la_que_nos_conectaremos
option encryption wep
option key 1
option key1 XXXXXXXXX #Aqui va la clave WEP de la red wireless


Archivo: /etc/config/network

config interface loopback

option ifname lo
option proto static
option ipaddr 127.0.0.1
option netmask 255.0.0.0

config interface lan

option ifname eth0
option type bridge
option proto static
option ipaddr 192.168.2.1
option netmask 255.255.255.0

config interface wan

option ifname ath0
option proto dhcp

Por último reiniciamos, o bien ejecutamos:

/etc/init.d/network restart



Fuente: fonera.info